Daylite Touch ist kompatibel mit iPhone, iPod Touch und iPad. Daylite Touch erfordert für Daylite 6 iOS 8.2 oder neuer. Jeder Daylite Benutzer kann eine unbegrenzte Anzahl an iOS-Geräten nutzen.